Click here to Skip to main content
15,794,275 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I have set a Scheduled Task that is meant to repeat an action every n minutes - say 5 minutes, for example.

The first time, the task runs smoothly, taking a mere few seconds to do the action it is meant to do. On subsequent runs however, the action does not happen unless I go and end it then rerun it manually - despite the task itself indicating it has ran.

What I have tried:

I have tried tweaking the repeat and duration times to see if any of these settings make the task hang, but to no avail. Again, the task is running, but without triggering the action it is meant to trigger.
Updated 11-Aug-23 1:05am
Richard Deeming 11-Aug-23 5:31am    
There's not much information to go on here. Have you checked the history of the task to see if there are any clues?

As a workaround, you could try changing the "Stop the task if it runs longer than" setting.

1 solution

Without knowing what the task is or does, or how it does it we really can't help you - I'd start by looking at what the task is executing, what the command and parameters are, and if possible it's source code.

If I had the source, I'd add logging info to give me some idea what path through the code it was taking, and that it genuinely terminated itself.

Without it, I'd be starting with the Task manager, and looking to see if it runs and then unloads itself.

But we can't do any of that for you!
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900