Click here to Skip to main content
15,796,025 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
I am running in a Docker container on an Ubuntu 22.04 machine. The machine has 2 nvidia tesla k80s installed. Both cards are functioning properly. I am currently using Codeproject.AI with Blue Iris and everything is running fine but it only works with CPU and not the 4 GPUs.

I cannot figure out where the issue is and how to get Codeproject to use the GPUs rather than the CPU.

What I have tried:

I have ensured that nvidia-smi works from both the machine and container.
I have ensured that nvidia is the default runtime for docker.
I have ensured that all GPUs are accessible to the container.
I have tried enabling the GPU for each module.
I have stopped and restarted the modules.
I have removed the container and persistent volumes multiple times.

Here is my Docker run command

sudo docker run --name CodeProject.AI -d -p 32168:32168 \
--gpus all \
--mount type=bind,source=/home/dax/docker/codeprojectai/ai,target=/etc/codeproject/ai \
--mount type=bind,source=/home/dax/docker/codeprojectai/modules,target=/app/modules \
--mount type=bind,source=/home/dax/docker/codeprojectai/custom-modules,target=/app/modules/ObjectDetectionYolo/custom-models \
Updated 29-Aug-23 3:27am

1 solution

Please post your question in the CodeProject.AI Discussions[^] forum.
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900