Click here to Skip to main content
15,844,602 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hello all,

I've made a small macro to ease the use of data for a customer.
In my computer, when I try to open the file, I get a yellow bar that asks me if I want to enable the content (macros) or not. If I decide to enable that content, then macros are enabled, and everything works as expected.

In my customer computer he is getting to messages: first one (yellow background) asking if he wants to enable content, and once he enables the content another one (light red background) saying "Microsoft blocked macros execution because the source of this file is not trusted".

Is there any way to make those files trusted like they are in my computer?

I've seen on the Internet that I could add new folders to the "trusted locations" but given this file will be copied in multiple folders this does not seem the best option.

Thank you all.

What I have tried:

Searching the internet to find out how to enable those macro files.
Posted
Comments
Richard MacCutchan 10-Oct-23 4:14am    
I think you can change this in explorer. Right click the file and check the Properties dialog.

1 solution

To the best of my knowledge, you can't do anything about this from your end: MS blocks macros in downloaded files as a security measure, and only the user can override that (as you would expect, if you could override that it wouldn't provide any security at all).

Your user will need to add the trusted location - you can't.
 
Share this answer
 
Comments
Joan M 10-Oct-23 4:27am    
Thanks OG!
Ralf Meier 10-Oct-23 4:29am    
... and also, as Richard has mentioned, with the Properties-Dialog of the File when using the Windows-Explorer ...

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900