Click here to Skip to main content
15,843,137 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
Hi friends
I am using Android 10 Gingerbread 2.3.9 version . I have tested my app on Emulator using Eclipse it works fine . Now I want to test my app on real device. For 

that I have googled a lot and found that we need to Download the Google USB Driver package from SDK Manager. 

I have downloaded and Update my driver from Device manager then it says Your driver is Updated Successfully. When I plug my Phone to PC in device manager I got 2 options like Spreadtrum Phone and  a Android Phone I have updated the driver for Android Phone and for the Spreadtrum Phone it shows a Yellow bar near left bottom corner. I dono what it was and googled to find a driver to update it also but could not figured out. I left that part and tried in another way.

I have connected my Phone to my PC and then copy the .apk file into my SD Card and then unplug the cable from my pc. then I click on my .apk file. I was 

unable to run and it gives me a messages says "There was a problem in parsing the Package".

so I thought to try to debug the app from eclipse when phone is connected. I have chosen the option as "Allow me to Pick a device every time" from Run 

Configurations". But I am unable to see my device in my Devices list also I tried from Command prompt "adb devices" it is not listed my phone which I 

connected.  I have Checked 'Unknown Resources" and also Checked " Use Debugging" in Developement menu option. but nothing solves my problem.

I have tried a lot of code samples and every one is doing in the same way but I could not figure out the problem. 
Please friends tell me what is the problem as I am not able to debug from my eclipse I can't figure out the problem from LogCat also.

Thanks
Ganesh
Posted

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900