Click here to Skip to main content
13,089,943 members (42,217 online)
Rate this:
Please Sign up or sign in to vote.
See more:
I use ms access as database to store data..When I use my software to save data on 32-bit PC,all data are saved successfully without any error..But when I use the same software on 64-bit PC,it throws below error"
System.Runtime.Interopservices.ComException(0x80040E07) Data type mismatch in criteria expression at ADODB.Connectionclass.execute(string.command text.object & RecordsAffected.Int32 options) at cmdSave_Click

I dont know why its creating problem on 64-bit...Please help me as soon as possible..I need to answer my clients asap..Thanx in advance..
Posted 18-Mar-13 23:51pm

1 solution

Rate this: bad
Please Sign up or sign in to vote.

Solution 1

Hi Rachna0309

Open your application in VS or VB which ever you use, then click 'Project', click 'Properties' and then click 'Compile' then click 'Advanced Compile Options'
and make sure the target cpu is set to X86, If that still doesn't work I would suggest
following this link and downloading both the packadges and add it as a pre-requisite to your application install or install the corresponding packadge on the machine that you want to run the application on.[
title="New Window">^

Please let me know if this worked for you

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy |
Web03 | 2.8.170813.1 | Last Updated 21 Mar 2013
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100