Click here to Skip to main content
14,881,640 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
hi all I created a website and programmatically puplished my website successfully puplished but iis giving error.

Error Summury:
HTTP Error 404.2 - Not Found
The page you are requesting cannot be served because of the ISAPI and CGI Restriction list settings on the Web server

most likely causes:
•No handler mapping for this request was found. A feature may have to be installed.
•The Web service extension for the requested resource is not enabled on the server.
•The mapping for the extension points to the incorrect location.
•The extension was misspelled in the browser or the Web server.

Things you can try:
•Install the feature that handles this request. For example, if you get this error for an .ASPX page, you may have to install ASP.NET via IIS setup.
•Verify that the Web service extension requested is enabled on the server.
1.Open the IIS Manager and navigate to the server level.
2.In the Features view, double-click ISAPI and CGI Restrictions to verify that the Web service extension is set to Allowed.
3.If the extension is not in the list, click Add in the Actions pane.
4.In the Add ISAPI and CGI Restrictions dialog box, type the path of the .dll or .exe file in the ISAPI or CGI Path box, or click Browse to navigate to the location of the file.
5.In the Description box, type a brief description of the restriction.
6.(Optional) Check "Allow extension path to execute" to allow the restriction to run automatically. If you do not check this option, the restriction status is Not Allowed, which is the default. You can allow the restriction later by selecting it and clicking Allow on the Actions pane.
7.Click OK.
NOTE: Make sure that this Web service extension or CGI is needed for your Web server before adding it to the list.
•Verify that the location of the extension is correct.
•Verify that the URL for the extension is spelled correctly both in the browser and the Web server.
•Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here.

I opne iis server and change isapiand cgi settings no use same error is giving

where I wrongly write coding?
Posted
Comments
ZurdoDev 25-Mar-13 7:56am
   
There is no way we can tell you what you did wrong with your coding because we can't see your coding. Have you tried deploying it manually? I have seen that error before and you usually need to do what it suggests. It is possible you need to reregister ASP.Net in IIS depending on what order things were installed.
U@007 25-Mar-13 8:02am
   
When I directly Open IId Create and Publish website successfully working fine.
So, don't worry about depending files.

1 solution

Hi,

Make sure the 4.0 items listed in the cgi / isapi restrictions are enabled (allowed)
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900