Click here to Skip to main content
15,848,930 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
hi.....!


Report Viewer Configuration Error

The Report Viewer Web Control HTTP Handler has not been registered in the application's web.config file. Add <add verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"> to the system.web/httpHandlers section of the web.config file, or add <add name="ReportViewerWebControlHandler" precondition="integratedMode" verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"> to the system.webServer/handlers section for Internet Information Services 7 or later.

so,

I added below code in web.config


<add verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a">




<add assembly="Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A">


<add name="ReportViewerWebControlHandler" precondition="integratedMode">
verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />


<
again same problem


pls .....

help
anyone....
Posted
Updated 15-Aug-18 8:57am

If you are using IIS 7.x or greater, then the handler ref needs to go under a new section of your web.config file and should look like this:

HTML
<system.webserver>
    <validation validateintegratedmodeconfiguration="false" />
    <handlers>
      ...
      <add name="ReportViewerWebControlHandler" precondition="integratedMode" verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
    </handlers>
    <modules>
    ...
    </modules>
</system.webserver>
 
Share this answer
 
I was also facing same problem of report viewer not displaying. After setting display property from browser i got my error as "Report Viewer Configuration error".

I have found that for some parameter i am sending incorrect values i.e. "string .empty". I changed my code to send some value or null to parameter. Now my report is displaying properly. I have resolved my issue by sending correct report parameter values to report. Don't miss any parameter to assign proper values or null.
 
Share this answer
 
Comments
Nalinda Wanigarathne 9-Apr-19 8:01am    
Wow Thanks Surekha Kolekar. i tries hours to resolve this. you saved my day.. Thanx again.. :* :* :*
you can use
	<system.webServer>
		
		
	
		<handlers accessPolicy="Read, Script">

<add name="ReportViewerWebControlHandler" preCondition="integratedMode" verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" />
<add name=".att" path="*.att" verb="*" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll" resourceType="File" preCondition="classicMode,runtimeVersionv2.0,bitness64" />
<add name=".htm" path="*.htm" verb="*" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll" resourceType="File" preCondition="classicMode,runtimeVersionv2.0,bitness64" />
		
	</handlers>

	</system.webServer>
 
Share this answer
 
See here same conversation..
http://forums.asp.net/t/1729518.aspx/1[^]
 
Share this answer
 
thanks Marc Gabrie, it worked.
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900