Click here to Skip to main content
15,904,652 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I use the below code in config file and I am trying to specify access to a particular person in the domain.

But the user is not getting windows authentication to that site, again and again its popping up of credentials ending up in 401 error. even after the name is added.

I am using IIS 7.0 and working from a remote machine.

In IIS, i tried windows authentication enabled, then anonymous enabled, but both didn't work.

XML
<authentication mode="Windows">
    </authentication>

    <authorization>
      <allow users="DomainName\UserName"/>
      <deny users="*"/>
    </authorization>
Posted

You can have a look at this

Windows Authentication[^]
 
Share this answer
 
Comments
Sai Janani 12-Sep-13 2:41am    
Hi,
Thanks for response.

Still, I am not getting the point. See, in the article its mentioned that i need to change the machine.config. I am working on a client network and can't do that. Other websites working in the same intranet use the same IIS and machine.config but when they use the above code, its working, but for my application tats developed, its not. I am wondering why.

Thank you.
Sai Janani 12-Sep-13 6:54am    
Its working now, after doing this, IIS restart was done and only windows authentication I enable where in advanced settings, Kernel mode was disabled and its working for me.
Its working now, after doing this, IIS restart was done and only windows authentication I enable where in advanced settings, Kernel mode was disabled and its working for me.
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900