Click here to Skip to main content
13,768,815 members
Rate this:
 
Please Sign up or sign in to vote.
I have created Telerik Report in HTML5 using reportViewer and connected it with oracle using connection string . I was having this error while connecting "Connection not open, i found out that oracle10g64 will not allow to connect visual studio with oracle if VS path look like this "C:\Program Files (x86)" with Brackets. I found solution and created directory "C:\Program Files x86" which indirectly is same path. I was able to create datasource and I can now Preview Telerik report (with data from oracle) in Visual Studio. Now am trying to open this report in Browser (opened from same path "C:\Program Files x86"), i get following error again.

An error has occurred while processing Table 'Table1': ORA-06413: Connection not open



Am stuck and unable to find solution for this problem. Kindly help.
Thanks in advance

Note: some one said this problem is you are running oracle_10g64 32bit on 64 bit machine, I have now installed oracle 11g along with oracle 10g and still facing same problem, already changed environment variable setting in my computer for oracle 11g.
Posted 26-May-14 22:30pm
Updated 8-Jun-16 12:02pm
v2
Comments
Waqas Ahmad Abbasi 27-May-14 6:51am
   
I googled this error and tried every possible solution.
1. created x86 directory without brackets
2. installed visual studio in C:\VisualStudio Path (Not in Program files)
3. Installed 64bit Oracle10g
4. Tried Oracle 11g
Still this problem exists. Kindly help
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

Regarding issue posted.
1- There is nothing to do with reportviewer, HTML5 or Telerik controls. Simple ORA indicates there is something wrong with you database connection

2- Inside web environment (on IIS Server) What we do is to set appPool 32Bit enabled so we would consume 32bit ORACLE version on 64bit machines.
FOR desktop environment you may try Properties -> Build -> Target Platform to x86 or AnyCPU
  Permalink  
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 2

Hi,

I have resolved by error after the days of searching:

Error Cause:
This error due to oracle reserved character "(",")" and in Windows 64 bit there is an folder "Program Files (x86)" is creation problem.

Solution:
Create a link folder for "Program Files (x86)" using below command on Window Drive path.

1).
Open cmd with administrator.
mklink /j "Program Files x86" "Program Files (x86)" ENTER
or visit link
http://www.download3k.com/articles/MKLink-Explained-Create-Symbolic-Links-that-Simplify-File-Management-in-Windows-Vista-7-and-8-00437

2).
open registry(with administrator)->Export Registry always backup a registry file before changing it.make a copy of registry file and work on copy.
Open Registry file(Copy) in text editor replace "(x86)" to "x86" Save file and import it in registry and restart you computer.

Now "ORA-06413: Connection not open" error go away.

Please rate this solution if your issue resolve.
Enjoy!

Shahzaib Zaheer
Software Engineer
shahzaibali88@hotmail.com
  Permalink  
v2
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 3

Do Solution 2, but don't edit the registry. Just create the link on command prompt:
mklink /j "Program Files x86" "Program Files (x86)" 

then press ENTER.

Then create a copy of the shortcut you use to launch Visual Studio and place it on your desktop - call it "Visual Studio (Oracle-safe)", but edit the path in the properties to be "Program Files x86" instead of "Program Files (x86)". Launch Visual Studio and open your project using this new shortcut, instead.
  Permalink  
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 4

This one work wiht me
mklink /j "Program Files x86" "Program Files (x86)"

Crystal Report Version = 11.5
Oracle Database Client (12.1.0.2.0) for Microsoft Windows (32-bit)
  Permalink  
Comments
Graeme_Grant 29-Jul-17 10:01am
   
Did you think that even though the OP accepted answers 3+ years ago, it still required answering? Please only answer current questions, not old or already answered ones.
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 5

Hi
The reason behind that in WIndows 7 & above operating system Visual Basic installed on c:\Program Files (x86) folder, so issue with this "(" & ")".

Simple Solution:
1) Go to C:\Program Files (x86) folder, find "Microsoft Visual Studio" folder then copy entire folder and paste to c:\Program Files

2) open "C:\Program Files\Microsoft Visual Studio\VB98" folder then find "VB.exe" file and open with administrator

3) Run your connection it will work.

Regards,

Yogesh Shimpi
  Permalink  
Comments
Richard Deeming 5-Sep-18 12:28pm
   
This "problem" was already mentioned in solution 2.

And solution 3.

And solution 4.

Also, your "solution" to this problem is absolute nonsense. You can't just copy Visual Studio to a new folder and expect it to work. You would need to uninstall it, and then install it in the new directory.
Member 13973890 14-Sep-18 4:45am
   
Dear Richard,
I hope you are alright,
Sorry, but I disagree with the solutions 2,3,4 it is very risky to play with registry.
Personnaly I tried to implement below code :
"mklink /j "Program Files x86" "Program Files (x86)"
sorry but it does not work for me :(

No need to uninstall and install Visual Studio, waste of time.


Regards,
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 6

I experienced the issue when i installed Oracle Workflow builder and forced it to be compatible with my Windows 10 OS. Then I started getting connection not open error.

Solution:

I copied the quest folder (For Toad) into my Oracle HOME folder(C:\app\user\product\11.1.0\client_1), create a shortcut for the toad application on my desktop then VIOLA, it worked.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Cookies | Terms of Service
Web01-2016 | 2.8.181116.1 | Last Updated 15 Oct 2018
Copyright © CodeProject, 1999-2018
All Rights Reserved.
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100