Click here to Skip to main content
15,918,976 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
I Have Made A Project in Visual Studio And I am Using AT Command With Nokia Cell Phone For sending sms iT IS Working Perfectly With English language but when i try to sending sms in other language like Arabic Urdu so it show ;like this ?????????????????
and when I Use Nokia PC Suit So It Works Perfectly all Language please I Need help
Posted
Updated 1-Jun-14 4:42am
v2

1 solution

You should change your current character set. The default is ISO 8859 Latin 1 for GSM

See through this url to see the allowed characters for this Character set.

http://www.ozekisms.com/mms:xml/mms-settings/video/GoIPsetup/index.php?owpn=209&info=appendix/e---sms-alphabet[^]


But, in this case, you can try use AT CSCS to change your current character set to the one you want to use. See this reference:
http://www.hughes.com/AT_Command_Reference.html#AT_plusCSCS[^]

Hope it helps :)
 
Share this answer
 
Comments
irfanansari 13-Feb-16 5:10am    
Sir This Site Not Working http://www.ozekisms.com/mms:xml/mms-settings/video/GoIPsetup/index.php?owpn=209&info=appendix/e---sms-alphabet[^]
irfanansari 10-Mar-16 6:20am    
please help me any other language getting out put like this ??????????

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900