Click here to Skip to main content
15,882,329 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
VS2013, Win7 (32-bit)

I'm writing a WPF app that utilizes MEF, and one of the modules (the one I'm testing) uses interop services. When I run the app to test the module, the app shuts down with no indication that anything is wrong. I've put try/catch blocks around the code where it stops, and no exceptions are being thrown.

In the IDE's output window, I get the following error:

The program '[37424] BODModules.vshost.exe' has exited with code -1073740791 (0xc0000409).

I've tried turning on debugging of unmanaged code, to no avail.

I have no idea why this is happening.
Posted
Comments
Rob Philpott 10-Sep-14 12:56pm    
Anything in the event log?
Rob Philpott 10-Sep-14 12:58pm    
define STATUS_STACK_BUFFER_OVERRUN ((NTSTATUS)0xC0000409L)

.. which (googling) suggests it might be strings aren't being handled correctly. BSTR type stuff.
#realJSOP 10-Sep-14 13:37pm    
I suppose that kinda makes sense...
I took out the code I thought might be the culprit, and no change...
Dave Kreskowiak 10-Sep-14 15:27pm    
Any 3rd party library being used? Could be blowing up in a call to that where .NET isn't going to see an exception.
#realJSOP 10-Sep-14 15:51pm    
Not in this case, no.


This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900