Click here to Skip to main content
15,918,516 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I have downloaded and added the dll of ajax control toolkit in my tool box.
I have added tab panel container in my web page,added three tab panels inside it;written something inside their respective ItemTemplate; before that added the scriptmanager.
But,when I am debugging,nothing is showing in the browser,I have tried the same with both website and webapplication.
What can be the reason?
I am using vs2008 and .net 3.5.
Thx in advance!
Posted

Hi,

have you set the HeaderText property of the TabPanels? Do you see the Header Text? Furthermore, have you set the ActiveTabIndex of the container to a valid panel number (e.g. 0 for your first Panel)?

In addition, the "Content-Template" is not called "ItemTemplate" but ContentTemplate.

Hope this helps a bit. If not, could you post your code?
 
Share this answer
 
Comments
avishekrc 19-May-10 9:10am    
Yes, I have set HeaderText Property of the tab panels and set the ActiveTabIndex to 0;
see below my code:
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Default.aspx.cs" Inherits="WebApplication5._Default" %>

<%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="asp" %>





<title>Untitled Page



<asp:scriptmanager id="ScriptManager1" runat="server">
<asp:tabcontainer id="TabContainer1" runat="server" activetabindex="0"
="" height="140px">
<asp:tabpanel runat="server" headertext="TabPanel1" id="TabPanel1">
<contenttemplate>
dfesgdsge


<asp:tabpanel id="TabPanel2" runat="server" headertext="TabPanel2">
<contenttemplate>
dxhgrsherherhe


<asp:tabpanel id="TabPanel3" runat="server" headertext="TabPanel3">
<contenttemplate>
ggggggggggggggtttttttttddddddddddd










avishekrc 19-May-10 9:11am    
sorry the code did not go,see below:
I have added my code in the add an answer section:
XML
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Default.aspx.cs" Inherits="WebApplication5._Default" %>
<%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="asp" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" >
<head runat="server">
    <title>Untitled Page</title>
</head>
<body>
    <form id="form1" runat="server">
    <asp:ScriptManager ID="ScriptManager1" runat="server"/>
    <asp:TabContainer ID="TabContainer1" runat="server" ActiveTabIndex="0"
        Height="140px">
        <asp:TabPanel runat="server" HeaderText="TabPanel1" ID="TabPanel1">
        <ContentTemplate>
        dfesgdsge
        </ContentTemplate>
        </asp:TabPanel>
        <asp:TabPanel ID="TabPanel2" runat="server" HeaderText="TabPanel2">
        <ContentTemplate>
        dxhgrsherherhe
        </ContentTemplate>
        </asp:TabPanel>
        <asp:TabPanel ID="TabPanel3" runat="server" HeaderText="TabPanel3">
        <ContentTemplate>
        ggggggggggggggtttttttttddddddddddd
        </ContentTemplate>
        </asp:TabPanel>
    </asp:TabContainer>
    <div>
    </div>
    </form>
</body>
</html>
 
Share this answer
 
Comments
michaelschmitt 19-May-10 9:44am    
Hm, i'm sorry - this looks 100% correct to me. I created that same page (by copy paste) and everything looks fine. I'm out of ideas right know, sorry..Hope someone else can solve this..I'm curious

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900