Click here to Skip to main content
15,878,748 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
XML
<?xml version="1.0"?>
<!--
  For more information on how to configure your ASP.NET application, please visit
  http://go.microsoft.com/fwlink/?LinkId=169433
  -->
<configuration>
  <add name="amitpandeyConnectionString" connectionString="Data Source=118.67.248.175\21;Integrated Security=True;User ID=Expresscargo;Password=;Encrypt=True;Application Name=600" providerName="System.Data.SqlClient" />
   </connectionStrings>


  
  <system.web>
    <authentication mode="Forms">
      <forms loginUrl="login.aspx" protection="All" timeout="30">
        <credentials passwordFormat="Clear">

        </credentials>
      </forms>
    </authentication>
    <compilation debug="true" targetFramework="4.5">

      <assemblies>
        <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
        <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
      </assemblies>
    </compilation>
    <httpRuntime targetFramework="4.5"/>
  </system.web>
</configuration>


I am getting

XML
<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>


XML
<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>

This error after I put my data on FTP. its working Fine on local computer. I am not able to workout the problem.
Posted
Updated 27-Nov-14 0:41am
v3
Comments
Duncan Edwards Jones 27-Nov-14 5:52am    
1) Can you post the actual text of the error message?

2) Can the remote machine see "MNT-PC\SQLEXPRESS" ?
Member 11111143 27-Nov-14 6:20am    
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a tag within a "web.config" configuration file located in the root directory of the current web application. This tag should then have its "mode" attribute set to "Off".
This is the error I am getting.
I have tried instred of machine name I have placed .\SQLEXPRESS but after that also the problem is same
Duncan Edwards Jones 27-Nov-14 6:29am    
1) SQLEXPRESS is (typically) a local database so if you want your application to run from a server then that server will need to have the database installed on it.

2) Using integrated security means that whatever user/account is running the code needs to have access to the database. This will be a system account so you need to give that account access.
Member 11111143 27-Nov-14 6:34am    
<connectionstrings>
<add name="amitpandeyConnectionString" connectionstring="Data Source=118.67.248.175\21;Integrated Security=True;User ID=Expresscargo;Password=amit@1702;Encrypt=True;Application Name=600" providername="System.Data.SqlClient">

I have used this connection String but this is not working too.
Member 11111143 27-Nov-14 6:45am    
Sir I have updated the Question with A new Connection String which i have used it in The past.But the error was the same. I have asked this question to many people But i did not get any exact answer any where.

1 solution

XML
Open tag of <CONNECTIONSTRINGS>

it will be as below.


<CONNECTIONSTRINGS>
<ADD name="amitpandeyConnectionString" providerName="System.Data.SqlClient" connectionString="Data Source=118.67.248.175\21;Integrated Security=True;User ID=Expresscargo;Password=;Encrypt=True;Application Name=600"></ADD>

</CONNECTIONSTRINGS>
 
Share this answer
 
Comments
[no name] 27-Nov-14 7:05am    
500 - Internal server error.
It is the problem with your hosted server.

Please check the below URL.

http://support.microsoft.com/kb/311766

Anf If you have a access to your Web Server then check the event viewer for IIS & Application level issues.
[no name] 27-Nov-14 7:16am    
What you have applied can you brief it ?
Member 11111143 27-Nov-14 7:24am    
instred of <connectionstrings> I applied <connectionstrings> and in place of <add> I placed <add> Then it showed me the above web config error
Member 11111143 27-Nov-14 7:58am    
instred of CONNECTIONSTRINGS I appliedconnectionstring and in place of ADD I placed add Then it showed me the above web config error
[no name] 27-Nov-14 8:03am    
Can you paste the code and error again ?

if you have server access with you? then kindly check the eventviewer to get the exact error of the particular web request.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900