Click here to Skip to main content
15,845,436 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
to start out, here is my environment:
I'm running windows server 2k3 sp2, with VS .net 2008 installed.
I have .net framework 2.0 sp1, 3.0 sp1, and 3.5 installed, and the various windows sdk's for vs 2008 (if a specific one is necessary I can list out what I have). I installed VS a while ago, but checking with the installation disk, it does show that I did make sure the web development components were selected as part of the original installation.

Looking in IIS, in the web site properties (both if I click on the overall 'web sites' folder, or the specific site i'm testing from), there is an ASP.net tab which shows my asp.net version as 2.0.50727, virtual path: web.config, location 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\config\web.config'

The asp.net web service extension is also present and set to Allowed, and the site I'm testing from has script execute permissions.

Now- when I try to run any asp.net page type, I get the error below:

<br />
Runtime Error Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.<br />
<br />
Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customerrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customerrors> tag should then have its "mode" attribute set to "Off".<br />
<br />
<br />
<!-- Web.Config Configuration File --><br />
<br />
<configuration><br />
    <system.web><br />
        <customerrors mode="Off" /><br />
    </system.web><br />
</configuration><br />
<br />
<br />
Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customerrors> configuration tag to point to a custom error page URL.<br />
<br />
<!-- Web.Config Configuration File --><br />
<br />
<configuration><br />
    <system.web><br />
        <customerrors mode="RemoteOnly" defaultredirect="mycustompage.htm" /><br />
    </system.web><br />
</configuration><br />
<br />
</customerrors></customerrors></customerrors>


I tried making the suggested changes in the web config file, but I see no change in the output. Also, when I try to debug from within visual studio- if I run from the 'development server' (localhost with a specified port) it works fine, but when I try to debug from he actual site (local iis), I get an error that it can't debug. It says
"the format of the specified network name was in valid"

The weird thing is, I just remembered I let a friend of mine test a site he was working on a while back that was asp.net based, and it used to work fine. I don't touch this machine much, so I'm not sure what could have changed...it's possible I installed a service pack or later .net framework version or something, but everything seems to point to the right framework dll... I'm really not sure what else to look for here. If anyone could hep me fiture this out, i would REALLY appreciate it!

(also, all other page types work fine on the server. I can access them without any issues)

Thanks
Posted

Did you change the debug setting via the web.config file in VS or via IIS.

I once had the issue where I was doing it through VS and it wasn't working but setting it in IIS worked.

Not much of a tip but hope this helps.
 
Share this answer
 
Comments
ryoaska 20-Jul-10 18:31pm    
what do you need to change in IIS? I did change it in VS but I didn't know I could change it in iis. I'm thinking it's something besides that though, because if it was only about debugging, at least other asp.net pages that previously worked would still work... it seems like it's some kind of setting that could have gotten changed by installing something else...idk. Getting VS debugging working is just the only way I can think of to track down what the real problem is here... If there's any other way I can debug this, I would really love to know

also the original error message I included got messed up.. it looks as below. I tried both edits to the web.config file and neither of those changed anything.
------------------------------------------------------------------------------
Runtime Error Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customerrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customerrors> tag should then have its "mode" attribute set to "Off".



<configuration>
<system.web>
<customerrors mode="Off">




Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customerrors> configuration tag to point to a custom error page URL.



<configuration>
<system.web>
<customerrors mode="RemoteOnly" defaultredirect="mycustompage.htm">

ok, apparently I can't put html in comments? error message should look like:
------------------------------------------------------------------------------
Runtime Error Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>
 
Share this answer
 
To check ASP version used by WebSite:
You said in InetMgr you see your website runs on 2.0.50727. When you test the Site in VS right click the development server icon in the taskbar and click show details. Do the two versions match?

Can you log on to the server and browse to http://127.0.0.1/MySite? What happens.

Alternatively if you want to debug via Visual Studio I found this on Code Project

[][^Remote Debugging]
Scroll down to were it says Remote IIS Debugging:
 
Share this answer
 
Comments
ryoaska 20-Jul-10 22:42pm    
I am testing it directly from the actual site, not from the VS development server (which from what I've ready uses some version of the mini web server 'matrix', and is not actually using iis). When I tried to run the project from the debug server it worked fine, but when I browse to the page on the actual site (i use the actual URL of the website , not localhost because I have multiple sites on the same ip using host headers) I get the error messaeg I pasted above. Since debugging in VS is giving me that "network name is invalid" error, I can't get to a point to check the status bar there (I think?). I'll look into that further.

when I created the project I did create it as a .net 2.0 project though. I'll see if I can find anything more specific in the project properties.

Thanks for the link, I'll check that out too.
Ah sorry, I thought you were on a workstation connecting to the server, not the server itself, I didn't read correctly (that is what your saying right?).

If that is the case what happens if you try the article [Here]?
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900