Click here to Skip to main content
15,446,613 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
I have created a WCF application with referring a third party service. While consuming the service using a console application, gets an error

"the client certificate not provided. specify a client certificate in client credentials."
Posted
Comments
John C Rayan 18-May-15 8:13am    
The webservice that you are trying to consume is a secured service. It is not for public use. If you are supposed to be allowed to access it then speak to your web service provider about the certificate.
normalsoft 18-May-15 8:19am     CRLF
Thank u for the quick reponse. I'm new in wcf. They have given the certificate and I have written code for trying to bypass the certificate using following code. it was working. But i think it may be problem of web.config file. ServicePointManager.ServerCertificateValidationCallback = delegate { return true; }
John C Rayan 18-May-15 8:43am    
How do you mean by "it was working"? it is clearly not. Why do you by-pass the certificate. You shouldn't do that. Without certificate you cannot access it
John C Rayan 18-May-15 8:45am     CRLF
Have a look at this and see if it helps you. http://www.codeproject.com/Articles/18601/An-easy-way-to-use-certificates-for-WCF-security
John C Rayan 18-May-15 8:48am     CRLF
One more link http://www.codeproject.com/Articles/36683/simple-steps-to-enable-X-certificates-on-WCF

1 solution

This is what you exactly need. Look at the bottom half.
Nine simple steps to enable X.509 certificates on WCF[^]
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900