Click here to Skip to main content
15,847,427 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
Hi friends

I am trying to execute automated test-cases on Microsoft Edge browser. While executing a test-case, Edge get launched, page get loaded but then it fails to execute javaScript (using IJavaScriptExecutor) and throw below exception:

C#
-> error: unknown error (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 31 milliseconds
Build info: version: '2.53.0', revision: '35ae25b', time: '2016-03-15 17:00:58'
System info: host: 'DESKTOP-VJGM30D', ip: '172.20.13.56', os.name: 'Windows 10', os.arch: 'amd64', os.version: '10.0', java.version: '1.8.0_60'
Driver info: org.openqa.selenium.edge.EdgeDriver
Capabilities [{acceptSslCerts=true, browserVersion=20.10240.16384.0, platformVersion=10, browserName=MicrosoftEdge, takesScreenshot=true, pageLoadStrategy=normal, takesElementScreenshot=true, platformName=windows, platform=ANY}]


However I discovered a workaround to execute JavaScript. Whenever you open a url in edge browser (through your automation-script), just open its developer tools (by pressing F12 key). It will then start executing JavaScript on edge browser. Have anyone faced similar issue and if yes what did you do to resolve that?

Second issue that I faced with edge browser is that I am not able to run test-cases in parallel on edge browser. I opened two instances of visual studio and run one test-case from each instance. I realized that both the instances of edge-webdriver were pointing to same edge-browser-instance. Please let me know if any of you faced this issue. If yes, then how could you run test-cases in parallel on same machine?

Third issue that I faced is that we can't run test-cases from a process that is running with Admin privileges. Its very strange that test-cases run fine when running without Admin privileges. Any input in that regard?

Please help. Also could you please suggest most stable version of edge-webdriver?

Kind Regards
Aseem

What I have tried:

I tried with three versions of edge WebDriver. But no success.
Posted
Updated 11-Apr-16 16:25pm
v2

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900