Click here to Skip to main content
15,916,951 members
Please Sign up or sign in to vote.
5.00/5 (1 vote)
I've been having a problem with installing packages in PyCharm. This started happening a few months ago, but before that it was fine. I can install it from the cmd using pip, but when I try to import it into the IDE it gives this error:

ModuleNotFoundError: No module named '_winreg'

and isn't available for use. The package I'm trying to install right now is pygame, but it has had trouble with other ones too. I tried to make sure I have winreg installed by using 'pip3 install winreg' in the cmd, but it gives error text saying, "Could not find a version that satisfies the requirement winreg."

Additionally, when I tried to reinstall using the CMD instead of the PyCharm installer, it says:

Requirement already satisfied: pygame in C:\Users\Me\AppData\Local\Programs\Python\Python36-32\Lib\site-packages

I actually found it in that directory, so it was already there. I'm guessing that means it's installed, but not in the right place. Where should it be?

Also, if it helps, I'm using Windows and the latest version of PyCharm, as well as python 3. Sorry if I worded this question weird, just ask if you need me to clarify what I meant. Thanks for the help!

What I have tried:

• CMD>'pip install pygame'

• CMD>'pip install winreg'

• CMD>'pip install _winreg'

• Pycharm>'import pygame', hovering over that red lightbulb that shows up and clicking "Install package pygame"
Updated 1-Apr-18 18:21pm

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900