Click here to Skip to main content
15,881,967 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hello everyone,

I'm stuck with a problem.

I have a web form which imports data from an excel sheet and displays it on gridview.
It works fine on IIS6.0 but when deployed to server which has IIS 7.0 installed on it with windows Vista, it is not importing the data.

Any suggestions/solutions?

I am using OLEDB object to import the data from Excel.
Is there any other way to import data so that conflict of IIS 7.0 is resolved?

Thank you.
Posted
Updated 2-Feb-11 22:23pm
v2
Comments
Dalek Dave 3-Feb-11 4:23am    
Edited for Grammar, Syntax and Readability.

1 solution

This is a known issue.
This Link[^] may help.

There are several problems, depending on your methodology, but hopefully this will help.
 
Share this answer
 
Comments
ahsan sarfraz 3-Feb-11 5:21am    
the link is not working its broken :(
Dalek Dave 3-Feb-11 5:25am    
No, working perfectly well from here.
ahsan sarfraz 3-Feb-11 5:42am    
sorry there was problem with internet.thankyou. but this is not the logic i am using. I am using OLEDB object to make a connection with Excel file and then read it.any other possible solution?
Dalek Dave 3-Feb-11 5:46am    
http://stackoverflow.com/questions/3151551/asp-net-oledb-code-breaks-when-deployed-on-iis7

Is an OLEDB response.
ahsan sarfraz 3-Feb-11 6:30am    
thankyou for your concern. :)

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900