Click here to Skip to main content
15,851,479 members
Please Sign up or sign in to vote.
4.00/5 (1 vote)
See more:
Hi

I have created a self signed certificate and apply to Default website (localhost). I got error.
[There is a problem with this website's security certificate. The security certificate presented by this website was not issued by a trusted certificate authority.

Security certificate problems may indicate an attempt to fool you or intercept data you send to the server.
We recommend that you close this webpage and do not continue to this Web site.]

How I can remove the error!
Posted
Updated 30-Aug-11 22:00pm
v3

1 solution

Your browser is correct:
SQL
The security certificate presented by this website was not issued by a trusted certificate authority.
In this case you issued the certificate and you are not a trusted certificate authority.

To make the message go away on one specific computer, you need to add yourself as a trusted CA.
How to make IE8 trust a self-signed certificate in 20 irritating steps
 1.Browse to the site whose certificate you want to trust.
 2.When told "There is a problem with this website's security certificate.", choose "Continue to this website (not recommended)."
 3.Select Tools->Internet Options.
 4.Select Security->Trusted sites->Sites.
 5.Confirm the URL matches, and click "Add" then "Close".
 6.Close the "Internet Options" dialog box with either "OK" or "Cancel".
 7.Refresh the current page.
 8.When told "There is a problem with this website's security certificate.", choose "Continue to this website (not recommended)."
 9.Click on "Certificate Error" at the right of the address bar and select "View certificates".
 10.Click on "Install Certificate...", then in the wizard, click "Next".
 11.On the next page select "Place all certificates in the following store".
 12.Click "Browse", select "Trusted Root Certification Authorities", and click "OK".
 13.Back in the wizard, click "Next", the "Finish".
 14.If you get a "Security Warning" message box, click "Yes".
 15.Dismiss the message box with "OK".
 16.Select Tools->Internet Options.
 17.Select Security->Trusted sites->Sites.
 18.Select the URL you just added, click "Remove", then "Close".
 19.Now shut down all running instances of IE, and start up IE again.
 20.The site's certificate should now be trusted.


Credit for list above

If you're trying to make the message go away for everyone, sorry! You need to buy an SSL certificate. Luckily they're dirt-cheap these days. You can probably find one for $30 if you shop around.
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900