Click here to Skip to main content
13,589,566 members
Rate this:
Please Sign up or sign in to vote.
See more:
I can't add service reference to SSL WCF Service from VS 2010.

There was an error downloading 'https:xxx.svc'. The request failed with HTTP status 403: Forbidden. Metadata contains a reference that cannot be resolved: 'https:xxx.svc'. The HTTP request was forbidden with client authentication scheme 'Anonymous'. The remote server returned an error: (403) Forbidden. If the service is defined in the current solution, try building the solution and adding the service reference again.

Please Help
Posted 15-Jan-13 2:55am
db7uk 15-Jan-13 15:47pm
IS this hosted in IIS or IIS Express / VS host.? Do you have a SSL cert installed? Are you using mixed HTTP / HTTPS requests......
Rate this: bad
Please Sign up or sign in to vote.

Solution 1

I faced this issue once & believe me I tried a lot but couldn't find any working solution to it.

U can do one thing.Check if anywhere it's requiring authentication.
& if u see everything right, then error is in VS_2010.

I'd suggest give a try to it in VS_2012.
Rate this: bad
Please Sign up or sign in to vote.

Solution 2

I figured it out, the problem was this "The page you are trying to access is secured with Secure Sockets Layer (SSL)." So i had to uncheck the 'Require SSL' option on IIS and it worked, my service reference was successfully added.

Thank you.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy | Cookies | Terms of Service
Web04 | 2.8.180615.1 | Last Updated 16 Jan 2013
Copyright © CodeProject, 1999-2018
All Rights Reserved.
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100