Click here to Skip to main content
15,120,326 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more: , +
we develope web application using asp.net webforms and active directory membership provider ,it work fine on local or on any server has our domain but when I published it on azure not work and return that message "Unable to establish secure connection with the server" my code on web config

HTML
<add name="ADConnectionString" connectionString="LDAP://HO-DCRW-V04.test.gov/DC=test,DC=gov"/>



    <membership defaultProvider="DefaultMembershipProvider">
      <providers>
<add name="DefaultMembershipProvider" type="System.Web.Security.ActiveDirectoryMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" attributeMapUsername="sAMAccountName" connectionStringName="ADConnectionString" connectionUsername="test\mynameaccount" connectionPassword="mypassword"/>
   </providers>
    </membership>

    <roleManager enabled="true" defaultProvider="ActiveDirectoryRoleProvider" cacheRolesInCookie="true" cookieName=".ASPXROLES" cookiePath="/" cookieTimeout="30" cookieRequireSSL="false" cookieSlidingExpiration="true" createPersistentCookie="false" cookieProtection="All">
      <providers>
<add name="ActiveDirectoryRoleProvider" connectionStringName="ADConnectionString" connectionUsername="adminuser" connectionPassword="adminpassword" attributeMapUsername="sAMAccountName" type="mysystemname.ActiveDirectoryRoleProvider"/>
  </providers>
    </roleManager>


how to solve it ?

What I have tried:

it work fine on local or on any server has our domain but when I published it on azure not work and return that message "Unable to establish secure connection with the server"
Posted

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900