Click here to Skip to main content
15,902,840 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi Friends,

I have a strange situation. I have a database server with SQL Server 2017 and upgraded it today to SQL Server 2019 (I need the String_Split function). On my DB server nothing changed I can do everything with SSMS. In the sql server config manager all protocols are enabled.

On my work machine I could connect to the db server with the sa account, but since the update to SQL Server 2019 my login via SSMS is refused.

If I start Visual Studio projects for web api's. I run them with F5 using the SA account without any problem.

What in SSMS is stopping me?

What I have tried:

- Tried via network in explorer and (re)set the network visibility option
- in VS2022 no problem in connecting to the db
- Azure studio cannot connect
- SSMS cannot connect
Updated 28-Dec-21 4:43am

1 solution

I found the problem!
When upgrading SQL Server the firewall of windows does not get updated. It still refers to the old server folders. Update you firewall rules and connections work again.
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900