Click here to Skip to main content
15,793,452 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
I have a solution in Visual Studio 2017 with 3 projects, the main and running one is Dashboard and manages the forms. AppBehaviour controls the operations that intermediate between the forms and the databases. DatabaseBehaviour is the one that interacts with the database and has the methods to do so, all the others go through it.

Solution Explorer

The database was designed at the time in SQL Server 12.0.2269, but now the .mdf is a local copy that is always generated with the program and is necessary for its operation. In other words, the database is offline and embedded with the application.

Database ubication
Database properties

With the intention of making the application compatible with Windows XP, the .NET Framework is in version 4.6 which, as far as I have been able to understand (I am not very expert in these matters), is compatible and comparable to .NET Framework 4 (which, again from what I have been able to find out, is compatible with Windows XP). I have also made the app prefer 32 bits if they are feasible.

Project properties

With this in mind, and having generated a Setup, I set about adding the prerequisites and, to my understanding, the .NET Framework 4.6 and SQL Server 2014 Express LocalDB packages should be present on the client (I'm including SP1 just in case). The SQL packages I had to install them from outside in the Click Once folder because they did not come standard in my Visual Studio 2017. I think I did it right.


However, when it comes time to install and run, only my laptop (where I developed the app) is able to boot and run normally with the program. My other computer (the desktop computer), also running Windows 10 (I'm not messing with Windows XP yet because I want to get it working first even if it's only on Windows 10), makes the attempt and doesn't even get to open the window.

Laptop opening program

What I have tried:

As I understand it, the laptop has some package that the desktop doesn't and that's why everything works normally on one but not on the other.

I have tried to fix the issue by adding packages like dotNetFx40 and directly putting all the .NET Framework in version 4, I have added later versions of SQL Express, and I have even added the Setup model that the project now has instead of the integrated Publishing in case there could be a problem with the database (which I doubt considering that if it always failed even my laptop could not start the program).

So, with no other options, after browsing through videos, forums and manuals, I ask for popular advice from you, the veterans and wise men of the community.

Many thanks in advance to anyone who spends a moment of their time on my case.
Updated 30-Jun-23 18:05pm
Graeme_Grant 30-Jun-23 22:17pm    

1 solution

Which Package(s)?
Make sure Build Action = Content, not None.

Also, check out this article: Silent ClickOnce Installer for Winform & WPF in C# & VB[^]
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900