Click here to Skip to main content
15,878,430 members
Please Sign up or sign in to vote.
5.00/5 (1 vote)
See more:
Hello - I had a previous installation of CPAI. I deleted it and re-installed the current version as of today. It installed successfully. However, without any input from me, it installed 3 modules - face detection, yolo v5.net and yolo v5 6.2. Note I don't have any GPU except the Intel UHD GPU built into my i7 CPU. I tried stopping the 6.2 and starting the .net object detection. It started successfully but I'm getting an error below, and object detection is not working in BLue Iris.

Here is system info and the error in the log:


LOG
14:12:28:System:           Windows
14:12:28:Operating System: Windows (Microsoft Windows 10.0.19045)
14:12:28:CPUs:             Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz (Intel)
14:12:28:                  1 CPU x 6 cores. 12 logical processors (x64)
14:12:28:GPU:              Intel(R) UHD Graphics 630 (1,024 MiB) (Intel Corporation)
14:12:28:                  Driver: 31.0.101.2121
14:12:28:System RAM:       16 GiB
14:12:28:Target:           Windows
14:12:28:BuildConfig:      Release
14:12:28:Execution Env:    Native
14:12:28:Runtime Env:      Production
14:12:28:.NET framework:   .NET 7.0.14
14:12:28:App DataDir:      C:\ProgramData\CodeProject\AI
14:12:28:Video adapter info:
14:12:28:  Intel(R) UHD Graphics 630:
14:12:28:    Driver Version     31.0.101.2121
14:12:28:    Video Processor    Intel(R) UHD Graphics Family
14:12:28:STARTING CODEPROJECT.AI SERVER
14:12:28:RUNTIMES_PATH             = C:\Program Files\CodeProject\AI\runtimes
14:12:28:PREINSTALLED_MODULES_PATH = C:\Program Files\CodeProject\AI\preinstalled-modules
14:12:28:MODULES_PATH              = C:\Program Files\CodeProject\AI\modules
14:12:28:PYTHON_PATH               = \bin\windows\%PYTHON_DIRECTORY%\venv\Scripts\python
14:12:28:Data Dir                  = C:\ProgramData\CodeProject\AI
14:12:28:Server version:   2.3.4-Beta
14:12:31:
14:12:31:Module 'Object Detection (YOLOv5 .NET)' 1.7.1 (ID: ObjectDetectionNet)
14:12:31:Module Path:   C:\Program Files\CodeProject\AI\modules\ObjectDetectionNet
14:12:31:AutoStart:     True
14:12:31:Queue:         objectdetection_queue
14:12:31:Platforms:     all,!macos-arm64
14:12:31:GPU Libraries: installed if available
14:12:31:GPU Enabled:   enabled
14:12:31:Parallelism:   0
14:12:31:Accelerator:
14:12:31:Half Precis.:  enable
14:12:31:Runtime:       dotnet
14:12:31:Runtime Loc:   Shared
14:12:31:FilePath:      ObjectDetectionNet.exe
14:12:31:Pre installed: False
14:12:31:Start pause:   1 sec
14:12:31:LogVerbosity:
14:12:31:Valid:         True
14:12:31:Environment Variables
14:12:31:CPAI_MODULE_ENABLE_GPU = True
14:12:31:CUSTOM_MODELS_DIR      = %CURRENT_MODULE_PATH%\custom-models
14:12:31:MODELS_DIR             = %CURRENT_MODULE_PATH%\assets
14:12:31:MODEL_SIZE             = MEDIUM
14:12:31:USE_CUDA               = True
14:12:31:
14:12:31:Started Object Detection (YOLOv5 .NET) module
14:12:31:ObjectDetectionNet.exe: Error:
14:12:31:ObjectDetectionNet.exe:   An assembly specified in the application dependencies manifest (ObjectDetectionNet.deps.json) has already been found but with a different file extension:
14:12:31:ObjectDetectionNet.exe:     package: 'ObjectDetectionNet', version: '1.4'
14:12:31:ObjectDetectionNet.exe:     path: 'ObjectDetectionNet.dll'
14:12:31:ObjectDetectionNet.exe:     previously found assembly: 'C:\Program Files\CodeProject\AI\modules\ObjectDetectionNet\ObjectDetectionNet.exe'
14:12:31:Module ObjectDetectionNet has shutdown
14:12:31:ObjectDetectionNet.exe: has exited
14:12:33:Server: This is the latest version
14:14:12:
14:14:12:Module 'Object Detection (YOLOv5 .NET)' 1.7.1 (ID: ObjectDetectionNet)
14:14:12:Module Path:   C:\Program Files\CodeProject\AI\modules\ObjectDetectionNet
14:14:12:AutoStart:     True
14:14:12:Queue:         objectdetection_queue
14:14:12:Platforms:     all,!macos-arm64
14:14:12:GPU Libraries: installed if available
14:14:12:GPU Enabled:   enabled
14:14:12:Parallelism:   0
14:14:12:Accelerator:
14:14:12:Half Precis.:  enable
14:14:12:Runtime:       dotnet
14:14:12:Runtime Loc:   Shared
14:14:12:FilePath:      ObjectDetectionNet.exe
14:14:12:Pre installed: False
14:14:12:Start pause:   1 sec
14:14:12:LogVerbosity:
14:14:12:Valid:         True
14:14:12:Environment Variables
14:14:12:CPAI_MODULE_ENABLE_GPU = True
14:14:12:CUSTOM_MODELS_DIR      = %CURRENT_MODULE_PATH%\custom-models
14:14:12:MODELS_DIR             = %CURRENT_MODULE_PATH%\assets
14:14:12:MODEL_SIZE             = MEDIUM
14:14:12:USE_CUDA               = True
14:14:12:
14:14:12:Started Object Detection (YOLOv5 .NET) module
14:14:12:ObjectDetectionNet.exe: Error:
14:14:12:ObjectDetectionNet.exe:   An assembly specified in the application dependencies manifest (ObjectDetectionNet.deps.json) has already been found but with a different file extension:
14:14:12:Module ObjectDetectionNet has shutdown
14:14:12:ObjectDetectionNet.exe:     package: 'ObjectDetectionNet', version: '1.4'
14:14:12:ObjectDetectionNet.exe:     path: 'ObjectDetectionNet.dll'
14:14:12:ObjectDetectionNet.exe: has exited
14:14:12:ObjectDetectionNet.exe:     previously found assembly: 'C:\Program Files\CodeProject\AI\modules\ObjectDetectionNet\ObjectDetectionNet.exe'


SYSTEM INFO

Server version:   2.3.4-Beta
System:           Windows
Operating System: Windows (Microsoft Windows 10.0.19045)
CPUs:             Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz (Intel)
                  1 CPU x 6 cores. 12 logical processors (x64)
GPU:              Intel(R) UHD Graphics 630 (1,024 MiB) (Intel Corporation) 
                  Driver: 31.0.101.2121
System RAM:       16 GiB
Target:           Windows
BuildConfig:      Release
Execution Env:    Native
Runtime Env:      Production
.NET framework:   .NET 7.0.14
Video adapter info:
  Intel(R) UHD Graphics 630:
    Driver Version     31.0.101.2121
    Video Processor    Intel(R) UHD Graphics Family
System GPU info:
  GPU 3D Usage       7%
  GPU RAM Usage      0
Global Environment variables:
  CPAI_APPROOTPATH = <root>
  CPAI_PORT        = 32168


What I have tried:

Stopping 6.2 and starting .net.
I reviewed the json file referred to in the error message but didn't find anything that stood out as an issue. There is indeed a dll and an exe with the same file name - but it's not clear to me if that is incorrect.
Posted
Comments
Richard Deeming 21-Dec-23 3:45am    
Questions about CodeProject.AI should be posted in the CodeProject.AI Discussions[^] forum.
ultradianguy 25-Dec-23 2:04am    
Happy to do so, but this is where I was taken when I clicked the link to ask a question in the CPAI server status page. So I guess someone needs to change that link?

Richard Deeming 2-Jan-24 6:00am    
I suspect that's the general "ask a question" link, rather than the CPAI-specific one.

It might be worth mentioning that in the bugs & suggestions[^] board - if it's a CPAI-specific page, then putting the generic "ask a question" link at the top could confuse a lot of people.

1 solution

Please post your question in the CodeProject.AI Discussions[^] forum.
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900