Click here to Skip to main content
15,878,809 members
Please Sign up or sign in to vote.
3.00/5 (2 votes)
See more:
Hi All,

I have an issues (linked slightly to yesterdays, thanks Pete). I have some code & I have a working program now comes the issue. It works in VS2008 so I copied the folder over took it to work opened it in VS2022 and it returns
Quote:
Severity Code Description Project File Line Suppression State
Error CS0234 The type or namespace name 'Resources' does not exist in the namespace 'RS232CommPort.Properties' (are you missing an assembly reference?) RS232CommPort D:\CommsTester using Delegates_Scales_Tester_HERE_THIS_ONE\C#CommsTesterEventHandler\AboutBox1.Designer.cs 143 Active

and
Quote:
Severity Code Description Project File Line Suppression State
Error Custom tool error: Data at the root level is invalid. Line 1, position 1. RS232CommPort D:\CommsTester using Delegates_Scales_Tester_HERE_THIS_ONE\C#CommsTesterEventHandler\Properties\Settings.settings

Stack Overflow gives advice about how to update the .NET version but I think I have done this and the errors don't point toward a dodgy NET version.

What I have tried:

Updating the .NET version, looking at the Resx file which was missing properties...
Posted
Comments
Graeme_Grant 21-Feb-24 3:52am    
Sometimes the Roslyn compiler gets confused. Try closing VS, then deleting he Bin & Obj folders in the project, then restart, restore NuGet packages, then recompile.
Richard Deeming 21-Feb-24 4:23am    
Sometimes you may also need to delete the hidden .vs folder as well.
glennPattonWork3 21-Feb-24 4:04am    
Appears to have worked, I thank you sir!

1 solution

To remove this from the unanswered questions list; this was answered in the comments on the question.
 
Share this answer
 
Comments
glennPattonWork3 23-Feb-24 14:36pm    
Sorry was unsure of what to do!

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900