Click here to Skip to main content
15,878,809 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
Hi All,
Another in the continuing saga, I have managed to get Vis Studio 2022 to open the project and I can build it all is good, but I am trying to run the Exe on Windows 10 (the test rig is built around Win 10) which is built in Win 11, I have changed the .NET version to 3.0 as it does not need anything fancy.
I have also updated the Win10 to the latest. Still not working, there must be a setting I can't see (or Google can't point me toward)

What I have tried:

Rolled back the .NET version...
Posted
Comments
Richard MacCutchan 21-Feb-24 11:23am    
"Still not working"
As we often say in this forum, "what does 'not working' mean"?
glennPattonWork3 21-Feb-24 12:24pm    
Won't run
0x01AA 21-Feb-24 11:28am    
Strange idea: Try to run it as admin Sometimes it helps ... e.g. when the application tries to open something in HKEY_LOCAL_MACHINE with write access
glennPattonWork3 21-Feb-24 12:27pm    
Because of security I can't run as admin!!(mutter,mutter...)

1 solution

Check your build type: if you are running a 32 bit system (Win 10 or 11) and building for a 64 bit EXE file, it won't work.

Then check it running it under the debugger rather than executing an EXE directly: that'll tell you if it works at all, will (hopefully) show you error messages if it doesn't, and allow you to step through code to find out how far it does get before crashing out.
 
Share this answer
 
Comments
glennPattonWork3 21-Feb-24 12:26pm    
Yup 32, 64 bit exe issue, working now!
0x01AA 21-Feb-24 12:44pm    
There is a button 'accept answer' ;)
OriginalGriff 22-Feb-24 1:07am    
Excellent!

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900