Click here to Skip to main content
15,920,468 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I've been running the codeproject ai server with Blue Iris for many months without issue, but have recently reinstalled it after upgrading to a CUDA supported GPU. It's now completely broken and shuts down shortly after booting.

Here's the log error
2024-05-18 15:13:28: detect_adapter.py: Traceback (most recent call last):
2024-05-18 15:13:28: detect_adapter.py:   File "C:\Program Files\CodeProject\AI\modules\ObjectDetectionYOLOv5-6.2\detect_adapter.py", line 12, in <module>
2024-05-18 15:13:28: detect_adapter.py:     from request_data import RequestData
2024-05-18 15:13:28: detect_adapter.py:   File "../../SDK/Python\request_data.py", line 8, in <module>
2024-05-18 15:13:28: detect_adapter.py:     from PIL import Image
2024-05-18 15:13:28: detect_adapter.py: ModuleNotFoundError: No module named 'PIL'


I'm trying to use Object Detection (YOLOv5 6.2) since I have CUDA v11.8 on a GeForce GTX 1050 ti
windows 10

How do I fix this error?

I should mention that the YOLOv5.NET isn't working either, and that both of these models aren't giving me the option of running them on the GPU.

Each time I try to start the server it crashes, and it totally unusable now.

What I have tried:

reinstalling multiple times
Tired installing the YOLOv5 .net, 3.1, and 6.2 modules. All are broken.
Posted

1 solution

Ask your question in the dedicated forum for it.

CodeProject.AI Discussions[^]
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900