Click here to Skip to main content
15,878,543 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more: (untagged)
Using Blue Iris ver. 5.8.2.5 and Code Project 2.4.7-Beta But can not get CodeProject to see the CUDA/GPU that I have using the Gefource GTX-1650

Server version:   2.4.7-Beta
System:           Windows
Operating System: Windows (Microsoft Windows 11 version 10.0.22621)
CPUs:             Intel(R) Core(TM) i7-9700 CPU @ 3.00GHz (Intel)
                  1 CPU x 8 cores. 8 logical processors (x64)
GPU (Primary):    NVIDIA GeForce GTX 1650 (4 GiB) (NVIDIA) 
                  Driver: 522.06, CUDA: 11.8 (up to: 11.8), Compute: 7.5, cuDNN: 
System RAM:       32 GiB
Platform:         Windows
BuildConfig:      Release
Execution Env:    Native
Runtime Env:      Production
.NET framework:   .NET 7.0.10
Default Python:
Video adapter info:
  VNC Mirror Driver:
    Driver Version     1.8.0.0
    Video Processor    
  DisplayLink USB Device:
    Driver Version     9.3.3324.0
    Video Processor    
  DisplayLink USB Device:
    Driver Version     9.3.3324.0
    Video Processor    
  Intel(R) UHD Graphics 630:
    Driver Version     30.0.101.1692
    Video Processor    Intel(R) UHD Graphics Family
  NVIDIA GeForce GTX 1650:
    Driver Version     31.0.15.2206
    Video Processor    NVIDIA GeForce GTX 1650
System GPU info:
  GPU 3D Usage       19%
  GPU RAM Usage      528 MiB
Global Environment variables:
  CPAI_APPROOTPATH = <root>
  CPAI_PORT        = 32168

******************************************
When I first installed CodeProject 2.4.7-Beta I was able to click on the configuration Gear for Object Detection (YOLOv5 6.2) and CUDA/GPU was a selection possibility but now all I get is: Model Size No selection for GPU The same thing goes for Facial recognition except it shows Half Precision

What I have tried:

I've uninstalled both Blue Iris and CodeProject. I re-installed both Nvidia driver and CUDA still no luck at seeing GPU option in CodeProject. It was doing the same with older version of CodeProject AI but the one time I had it working until I was playing with the drivers is when I updated from an older version of CodeProject to the lates 2.4.7-Beta
Posted
Comments
RedDk 28-Dec-23 13:16pm    
Surely no one would mind if you reposted this here, where you're more likely to be scrutinized by those with a better AI eye: https://www.codeproject.com/Feature/CodeProjectAI-Discussions.aspx
0x01AA 28-Dec-23 15:17pm    

1 solution

Use the dedicated forum as suggested: CodeProject.AI Discussions[^]

Answered only to remove from the unanswered list.
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900