Click here to Skip to main content
15,884,472 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I have a site which is using access database.It runs properly on local machine(32 bit windows 7).When i publish it on Windows server 2012(64 bit) it gives me error while connecting to database "Object reference not set".Also i have googled for this error.
Tried the following..
Enable32biton64bit ="true" in iis.
executed C:\Windows\SysWOW64\odbcad32.exe also.But error still occurs.
Why so?How to remove this error step by step?Help me..I am stuck.

thanks in advance..
Vi(ky 26-Jun-14 3:07am    
make sure Access Database Engine installed on target machine. You can download it from here
pwavell 26-Jun-14 3:11am    
after installing access database engine are there any other things or steps that i have to follow or just downloading access database engine will be enough to run my web site?
pwavell 26-Jun-14 3:22am    
downloaded the engine.Still getting the same error.
pwavell 28-Jun-14 1:31am    
Please help me...

1 solution

Try debugging of publish code.
Here is the Link for how to.
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900