Click here to Skip to main content
13,699,798 members
Rate this:
 
Please Sign up or sign in to vote.
Hi All,
I am developing an asp.net c# web-application to sign documents on the server side. I am using a USB dongle to sign the documents. When i developed on the development box, I can able to sign the document. But when the same code is hosted on IIS , I cannot able to sign the document. I am not getting any exception too. The error provided is An Internal error occurred.

I got stuck on this stage. Please help me on this issue.
Posted 9-Sep-14 1:56am
Updated 12-Jun-18 21:06pm
Comments
‭011111100010‬ 9-Sep-14 8:00am
   
The USB will have to be plugged into the server right? Because that is where the code is running that is trying to access the USB.
S.Prasath 9-Sep-14 8:01am
   
Absolutely. Its connected.
‭011111100010‬ 9-Sep-14 12:44pm
   
1. Reply to comment so that the user is notified.
2. Then it is probably a permissions issue. Check which user is running the app pool in IIS.
S.Prasath 9-Sep-14 22:45pm
   
May be. But I have a question like "Do the IIS(with full rights) itself cannot able to access the external hardware(USB Token)?"
‭011111100010‬ 10-Sep-14 7:12am
   
Depends on what identity the app pool is using.
S.Prasath 10-Sep-14 7:48am
   
I tried with Network service and also local Administrator. Getting the same issue my friend.
‭011111100010‬ 10-Sep-14 7:50am
   
I would suggest trying an admin account.
S.Prasath 10-Sep-14 7:52am
   
Even I tried adding the administrator to the IIS_USER group, but it didnt solve my issue....
‭011111100010‬ 10-Sep-14 7:53am
   
Create an admin account and try that one. Also look in event viewer or your own logging to see if there is additional details.
S.Prasath 10-Sep-14 7:55am
   
Ok... I will give a try and update you the result shortly...
S.Prasath 10-Sep-14 8:35am
   
I created a admin account and run the application in it. Still no result my friend.
‭011111100010‬ 10-Sep-14 8:39am
   
Then you need to look in event viewer and find more details about the error, for example, the stack trace.
S.Prasath 11-Sep-14 1:51am
   
I have checked with both event viewer and sysinternals process moniter. I cant find any Errors loggged.
S.Prasath 15-Sep-14 6:43am
   
Guyz... Any update?
kshamaporwal 19-Jan-16 23:40pm
   
Guy..Any way forward for this?I am facing the same issue.

Thanks a lot in advance.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Cookies | Terms of Service
Web05-2016 | 2.8.180910.1 | Last Updated 13 Jun 2018
Copyright © CodeProject, 1999-2018
All Rights Reserved.
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100