Click here to Skip to main content
15,906,624 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I have an asp.net application hosted on Godaddy. I am using ASP.net authentication. When I run the app locally I have no problems logging in. When I run it on the Godaddy server, I can log in a few times and then suddenly it doesn't accept my login and just keeps sending me back to the login page with no error message whatsoever. It will then not let me log in for 20 minutes after which I can log in again. They tell me on Godaddy that my app pool is getting filled up. If I reset the app pool I can then log in again. I have no idea why and either do they - they have no idea how to give support for asp.net applications especially using SQL Server which is what I am using. I have wasted DAYS on this problem. Could someone please help!?!

Here is a my web config:

XML
<?xml version="1.0" encoding="utf-8"?>

<configuration>
  <configSections>
    <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 -->
    <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
  </configSections>
  <connectionStrings>
   <remove name="LocalSqlServer"/>
   <add name="LocalSqlServer" connectionString="Data Source=*****;Initial Catalog=****;Integrated Security=False;User Id=****; Password=*****" providerName="System.Data.SqlClient" />

<remove name="DefaultConnection"/>  
<add name="DefaultConnection" connectionString="Data Source=*****;Initial Catalog=****;Integrated Security=False;User Id=****; Password=*****" providerName="System.Data.SqlClient" />
 
  </connectionStrings>
  <system.web>
 <machineKey   validationKey="2A654FDADFA3C3A40F59130E44D92E369AED5E4A929AE5F74DC418CFA2D3045BF5B4384F893F90B317E2CD0CC4389A18F2194287689ED64445939C1262801E63" decryptionKey="548F73940555EBCB50A8169CDA0131CBC2675C70165BBDC382AA9F06AFD8119F" validation="SHA1" decryption="AES" />
  <globalization uiCulture="en-US" culture="he-IL" />
    <customErrors mode="Off" />
    <trust level="Full" />
     <authentication mode="Forms">
       <forms name="Aveida" path="/" loginUrl="Account/Login.aspx" protection="All" timeout="30" />
    </authentication>
    <compilation debug="false" targetFramework="4.5" />
    <httpRuntime targetFramework="4.5" />
    <pages>
      <namespaces>
        <add namespace="System.Web.Optimization" />
        <add namespace="Microsoft.AspNet.Identity" />
      </namespaces>
      <controls>
        <add assembly="Microsoft.AspNet.Web.Optimization.WebForms" namespace="Microsoft.AspNet.Web.Optimization.WebForms" tagPrefix="webopt" />
      <add tagPrefix="ajaxToolkit" assembly="AjaxControlToolkit" namespace="AjaxControlToolkit" /></controls>
    </pages>
    <membership>
      <providers>
        <!--
	      ASP.NET Membership is disabled in this template. Please visit the following link http://go.microsoft.com/fwlink/?LinkId=301889 to learn about the ASP.NET Membership support in this template
        -->
        <clear />
<add name="AspNetSqlMembershipProvider"

                    type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"

                    connectionStringName="LocalSqlServer"

                    enablePasswordRetrieval="false"

                    enablePasswordReset="false"

                    requiresQuestionAndAnswer="false"

  requiresUniqueEmail="false"

                    passwordFormat="Hashed"

                    maxInvalidPasswordAttempts="5"

                    minRequiredPasswordLength="5"

                    minRequiredNonalphanumericCharacters="1"

                    passwordAttemptWindow="10"

                    passwordStrengthRegularExpression=""

                    applicationName="/****"

                />
      </providers>
    </membership>
    <profile>
      <providers>
        <!--
	      ASP.NET Membership Profile is disabled in this template. Please visit the following link http://go.microsoft.com/fwlink/?LinkId=301889 to learn about the ASP.NET Membership support in this template
        -->
        <clear />
      </providers>
    </profile>
    <roleManager>
      <!--
	        ASP.NET Membership Role is disabled in this template. Please visit the following link http://go.microsoft.com/fwlink/?LinkId=301889 to learn about the ASP.NET Membership support in this template
        -->
      <providers>
        <clear />
      </providers>
    </roleManager>
    <!--
            If you are deploying to a cloud environment that has multiple web server instances,
            you should change session state mode from "InProc" to "Custom". In addition,
            change the connection string named "DefaultConnection" to connect to an instance
            of SQL Server (including SQL Azure and SQL  Compact) instead of to SQL Server Express.
      -->
    <!--<sessionState mode="Custom" customProvider="DefaultSessionProvider">-->
     <sessionState mode="InProc">
 
      <!--<providers>
        <add name="DefaultSessionProvider" type="System.Web.Providers.DefaultSessionStateProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="LocalSqlServer" />
      </providers>-->
    </sessionState>
 
     

  </system.web>
  <system.webServer>
    <modules>
      <remove name="FormsAuthenticationModule" />
    </modules>
  </system.webServer>
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="WebGrease" culture="neutral" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="0.0.0.0-1.5.2.14234" newVersion="1.5.2.14234" />
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
  <entityFramework>
    <defaultConnectionFactory type="System.Data.Entity.Infrastructure.SqlConnectionFactory, EntityFramework" />
    <providers>
      <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
    </providers>
  </entityFramework>

<location path="SearchLost.aspx">
    <system.web>
      <authorization>
        <allow roles="member,manager" />
        <deny users="*" />

       </authorization>
    </system.web>
  </location>
  <location path="Account/Register.aspx">
    <system.web>
      <authorization>
        <allow roles="manager" />
        <deny users="*" />
       </authorization>
    </system.web>
  </location>
<location path="Categories.aspx">
    <system.web>
      <authorization>
        <allow roles="manager" />
        <deny users="*" />
       
      </authorization>
    </system.web>
  </location>
   <location path="Items.aspx">
    <system.web>
      <authorization>
        <allow roles="manager" />
        <deny users="*" />
       
      </authorization>
    </system.web>
  </location>
  <location path="Cities.aspx">
    <system.web>
      <authorization>
        <allow roles="manager" />
        <deny users="*" />
       
      </authorization>
    </system.web>
  </location>
  <location path="Neighborhoods.aspx">
    <system.web>
      <authorization>
        <allow roles="manager" />
        <deny users="*" />
       
      </authorization>
    </system.web>
  </location>
</configuration>
Posted
Updated 17-Apr-23 20:16pm
v3
Comments
Kornfeld Eliyahu Peter 21-Dec-14 2:56am    
It sounds very, strange...but it seems that every attempt to login creates a new application in the application pool, and when it is full it blocks you...try to check number of applications in application pool after each login...
kellykzevy 22-Dec-14 14:53pm    
do you know how i would see that on godaddy?

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900