Click here to Skip to main content
15,916,951 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more: , +
So I have now been searching hours for why I cannot start debugging a .dll of mine runned by a third-party process by attaching the .dll process to the visual studio debugger.
This is because there is no just-in-time debugger registered and enabled on my machine.
The JIT debugger can be turned on, according to all documentation in the world, by going into Tools->Options->Debugging->Just-In-Time

BUT

I do not have this in my visual studio express 2013 version. Is JIT debugging only available on "normal" visual studio versions ?

Thanks,
RaGE

What I have tried:

I have tried about all what I could find on solving the problem on Google:
- some regedit of the vsjitdebugger.exe
- repair my installation
- regsvr the oleaut32.dll
Posted

1 solution

I don't know about Express, but don't use it; it's not good enough. Better use another free-of-charge version: 2013 or 2015 Community Edition. In features, these editions are close or equivalent to "normal" Professional bundles.

Probably, for fixing your debugging problem we don't have enough information; but I never experienced any fundamental debugging problems, including more difficult cases with debugger attachment.

—SA
 
Share this answer
 
v2
Comments
Rage 12-Feb-16 11:13am    
Thanks. I get a bit confused with all the different versions, to be honest... and the Microsoft documentation does not really help.
What is the difference between Express and Community ? I tried the community version already, but it expired after 30 days, so it does not seem to be free of charge ( Microsoft wanted a code from me to continue using it) : http://stackoverflow.com/questions/32235116/visual-studio-community-2015-expiration-date

To my problem : I am writing a c++ plug-in for a third-party tool, so this dll only gets loaded at runtime. I need to start the tool, perform some operations, and only then my dll gets loaded. Attaching the process from within Visual Studio at that point of time does not succeed : the debugger starts, but my breakpoints are disabled. I managed to get my dll attached by the debugger by stopping the program flow with a message box, attaching the debugger using the Debug option from the windwos task manager on my process, which would just fire up visual studio in debugger mode (I think this goes over VSJitdebugger.exe, which is called by the task manager). But this is exactly what is not available in the express edition.

The cost of VS is outrageously enormous compared with the 30 lines .dll code I need to develop, but I think the choices are narrow...
Sergey Alexandrovich Kryukov 12-Feb-16 11:38am    
You need to have MSDN membership (free without subscription) and register your Community application after the expiration. It will give you the permanent license. I recently had the same situation. On top of it, I later installed Professional of next version; all works.

I've done attachment of the debugger recently; never had a problem.

—SA
Rage 12-Feb-16 11:47am    
With MSDN membership, you mean Microsoft account, correct ? I think it is one and the same.
Sergey Alexandrovich Kryukov 12-Feb-16 11:50am    
You really need one personal account, always the same, no matter where you work:
MSDN account.
—SA
Rage 15-Feb-16 3:33am    
Hi SA, just did as you mentioned, and it worked like a charm. Many thanks !

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900