Click here to Skip to main content
15,846,342 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
I've made a small program by visual studio 2012 contain print procedure using report viewer
it's working ok in my PC , but after deploying program using Advanced Installer program and install it in another PC it gives error in printing form as shown in the following picture
http://a.up-00.com/2019/02/155040341568781.png[^]

Quote:
An error occurred during local report processing
The definition of the report '' is invalid
An unexpected error occurred in Report Processing
Could not load file or assembly 'Microsoft.SqlServer.Types, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified.


What I have tried:

How can I solve this Problem ?
And what's the best way to deploy my program without having any error ?
Posted
Updated 18-Feb-19 4:47am
v2
Comments
OriginalGriff 17-Feb-19 7:42am    
No idea.
Mostly, because that image is so poor you can't really read it.

Instead of posting links to unreadable pictures of error messages (which is probably partly why your question got sent to moderation) copy and paste the text of the error message into your question so we can actually read it.

But first, copy the text of the error and paste it into Google. Chances are it'll give you some help , or maybe even a solution...

Use the "Improve question" widget to edit your question and provide better information.
Kornfeld Eliyahu Peter 17-Feb-19 9:23am    
It states the SQL isn't installed on the machine, so it can not find the Server and the report in it...
boudyonline 18-Feb-19 6:45am    
it's already installed and program working ok but not for report
CHill60 18-Feb-19 7:17am    
What does the full error actually say? I can't follow your link because I am at work - which is why OriginalGriff told you to post the text so that we can actually read it ... 24 hours ago! Help us to help you - follow our instructions
boudyonline 27-Feb-19 5:15am    
it doesn't work
here's the pic again
http://b.up-00.com/2019/02/15512624624611.png[^]

For some reason the specific version of the SQL assembly that your app needs is not installed on the machine, or one of the files it depends on. It may be that there us a later version installed in the GAC so your installation program skipped adding the older version, but we can't tell from here.

I'd suggest contacting the people who wrote Advanced Installer - I've never heard of it, much less used it - and asking them for help directly as they will undoubtedly know how it does things a lot better than we will!
 
Share this answer
 
The reason was that file should be install
SQLSysClrTypes


after that it working well

Thanks for all
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900