Click here to Skip to main content
15,916,951 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
I have a big problem with opening website. I have building website months. Yesterday I have install a fresh Windows7, and after that install Visual Web Developer 2010 express from which I have build website.
Now when I open webiste in Web Developer, and browse with Internet it wont open. And also in Web Developer getting on each website huge Warnings.
1. D:\<path>Webisite\details.aspx: runtime error: Could not load file or assembly ''Xheo.licensing Version= 2,0,3300,0.
2. This name contains uppercase characters, which is not allowed
3. Unrecognized tag prefix or device filter 'asp'.
4. ....
5. ....

On this site I have 7315 Warnings.

I'm totaly lost about this.

Thanks in advance for help to anyone.

and thank you for reply.

I have install all IIS features.
I have also install all VS tools from installation, and almost all warnings has gone, except one has left

I'm suprised that on the web there is no solution for this issue. I have checked a lot posts.

Any idea Marcus?

Here is error when try to open my page:

Server Error in '/backup v10' Application.

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'Xheo.Licensing, Version=2.0.3300.0, Culture=neutral, PublicKeyToken=798276055709c98a' or one of its dependencies. The system cannot find the file specified.

Source Error:

Line 37: <assemblies>
Line 38: <add assembly="System.Management, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
Line 39: <add assembly="Xheo.Licensing, Version=2.0.3300.0, Culture=neutral, PublicKeyToken=798276055709C98A"/></assemblies></compilation>
Line 40: </system.web>
Line 41: </configuration>

Source File: D:\BACKUP FILES\SPLETNE STRANI\VISUAL STUDIO\Backup\backup v10\web.config Line: 39

Assembly Load Trace: The following information can be helpful to determine why the assembly 'Xheo.Licensing, Version=2.0.3300.0, Culture=neutral, PublicKeyToken=798276055709c98a' could not be loaded.

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1
Updated 17-May-11 12:42pm
senguptaamlan 17-May-11 8:44am    
what was your previous OS ?
Sergey Alexandrovich Kryukov 17-May-11 18:44pm    
The web.config file is placed in the directory named "....\Gossips_of_the_country\..." (in translation to English). Ha!

It looks to me like you had some 3rd party tools installed or referenced by your web application which are no longer available. Identify and reinstall those first. As well, if your site uses classic asp, you will need to add the support for it in IIS7 using "Control Panel/Programs/Windows Features/Internet Information Services/Www services/Application Development Features/ASP"
Share this answer
Sergey Alexandrovich Kryukov 17-May-11 18:44pm    
Good advice, a 5.
I have find solution.

1. I didn't install also other tools from VS installation. So, all warnings has gone, except 'Xheo.licensing' left.
2. For Xheo I have in website's Web.config file delete Xheo.licenings assembly line.

But still I do not know how did I get Xheo assembly.
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900