Click here to Skip to main content
15,851,453 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi, i have created a setup project for my application and select these prerequisites for it:

1. Microsoft .NET Framework 4 (x86 and x64)
2. SQL Server 2008 Express
3. Windows Installer 4.5

but i receive following warning when i build it:

The value of the 'public key' attribute in 'Microsoft .NET Framework 4(x86 and x64)' does not match that of file 'C:\Program files\Microsoft SDKs\Windows\V7.0A\Bootstrapper\Packages\DotNetFx40\DotNetFx40_Full_x86_x64.exe'.
Posted

1 solution

I am not sure, but i think the error is due to .NET Framework mismatch.
Try installing .Net framework 2.0 Service Pack 1 and 2, and .net framework 3.5 also alongwith it.

Hope this helps you :)
 
Share this answer
 
Comments
M_Mogharrabi 5-Sep-11 1:15am    
why should i install .Net framework 2.0 and 3.5? i want to use .Net framework 4.0
HarinderS 5-Sep-11 1:24am    
Just to avoid error, try it, and then tell if it works or not??

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900