Click here to Skip to main content
15,851,701 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi Guys

I have created a couple of packages in a SSIS 2008 with BIDS project. Let me mention that I created these packages on a 32-bit machine and deployed them on a 32 bit Windows Server 2008 about 2 months ago. Everything worked fine and the data was successfully imported from MS Access database to SQL server without any error or warning.

Now after 2 months the packages suddenly stopped working and began giving error messages which are not much useful:

[OLE DB Destination [25]] Error: SSIS Error Code DTS_E_OLEDBERROR.  An OLE DB error has occurred. Error code: 0x80040E37.
An OLE DB record is available.  Source: "Microsoft OLE DB Provider for SQL Server"  Hresult: 0x80040E37  Description: "Table does not exist.".

[OLE DB Destination [25]] Error: Opening a rowset for " [MyTable1]" failed. Check that the object exists in the database.

[SSIS.Pipeline] Error: "component "OLE DB Destination" (25)" failed validation and returned validation status "VS_ISBROKEN".

I checked that my destination table does exists. But still the error message says that it does not exists.

I forcefully set the 'Use64bitRuntime=false' for the project property.

I tried setting the property 'DelayValidation =false' which was recommended on tech blogs and worked for a number of users . But it did not resolve my issue. The package still fails with the same error mentioned above. I read through dozens of blogs online, but I couldn't seem to find the reason. I suspect the culprit is the difference between 32 and 64 bit oledb drivers.

Please let me know if anybody faced a similar problem and was he able to resolve it by any ways.

Suggestions, clarifications and reference links are all welcome...
Updated 26-Sep-12 7:13am

1 solution

Yes, it's the 64 bit compatibility of ACE OLEDB drivers. You have two options.

1. Force the package execution to 32 bit mode.
2. Install latest ACE OLEDB drivers:[^]

If yo are using SQL Agent Job to run/schedule package, ther's is an option to use 32 bit mode.
If you run the package individually use 32 bit dtexec.exe with /X86 falg:[^]
Share this answer
bbirajdar 27-Sep-12 6:50am    
Thank you Kuthu.. I will try your suggestion. In fact I had the same thing in my mind, but I needed confirmation from somebody else since the package is to be deployed on client's machine. Currently waiting for client's approval to install the redistributable.
Till then 5+ for the solution
Let me note here that the MS Office 2010 installed on client's machine has expired. I think this has certainly to do something with the issue.
Kuthuparakkal 27-Sep-12 6:53am    
The driver (JET, OLEDB 12.0, OLEDB 14.0) etc does not of any dependancies on MS Office. They are independent and they work without MS Office installed!!! I pointed to you to ACE driver, not any MS Office component.
bbirajdar 27-Sep-12 7:12am    
Okay.. Thanks..

I will try with installing the ACE drivers..
bbirajdar 27-Sep-12 7:13am    
Is there anyway I can check if these ACE driver is installed on the machine?
Kuthuparakkal 27-Sep-12 7:20am    
Okay it's simple:
1. Office 2007 or later work with ACE drivers(they dont work with JET drivers. So create a sample package and try to import any xlsx files.
2. Check registry :

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900