Click here to Skip to main content
15,845,681 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
what can i use for varchar(8000) to make it compatible in Oracle 9i
i tried using long but ive more than one cols having varchar(8000) so dLong does not work i even tried clob but its giving me this error
[Execute SQL Task] Error: Executing the query 
"CREATE TABLE "PH_TxnReview" ( "ReviewId" VARCHAR2(100) NOT NULL, "PoornataId" VARCHAR2(100) NOT NULL, "Year" VARCHAR2(50), "ReviewType" VARCHAR2(10) NOT NULL, "SendDate" VARCHAR2(100), "SendMail" NUMBER(1,0), "IsApprove" NUMBER(1,0), "ApprovedBy" VARCHAR2(100), "ApprovedDate" VARCHAR2(100), "OverallEmpComments" CLOB, "OverallMgrComments" CLOB, "StrengthExhibited" CLOB, "ImprovementOpportunity" CLOB, "SupportRequired" CLOB, "CreatedBy" VARCHAR2(100), "CreatedDate" VARCHAR2(100), "ModifiedBy" VARCHAR2(100), "ModifiedDate" VARCHAR2(100), "SendNotificationToMgrDate" VARCHAR2(100) ) " failed with the following error: "ORA-01658: unable to create INITIAL extent for segment in tablespace USERS ". Possible failure reasons: Problems with the query, "ResultSet" property not set correctly, parameters not set correctly, or connection not established correctly. 

please help , Thanks in Advance !!!!!
Posted
Updated 1-Nov-12 2:59am
v2

1 solution

VARCHAR2 on Oracle 9i can store up to 4000 chars : http://ss64.com/ora/syntax-datatypes.html[^]

So you should be fine with that otherwise you should use CLOB.

The error ORA-01658 refers to the lack of space in the storage files : http://www.dba-oracle.com/sf_ora_01658_unable_to_create_initial_extent_for_segment_in_tablespace_string.htm[^]
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900