Click here to Skip to main content
15,846,346 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
Good evenig.

I'm wondering if there is away to remote debug MVC application running on Apache server from Visual Studio.
This is equipped with Mod_mono and Mono-server4 and it hosts the web site in a Lan.

I'm using Visual Studio in other PC connected to the same Lan. I need to debug some compatibility problems in Linux, so I'm looking for solution. I desired to connect remotely Visual Studio to apache server in Linux.

There is a solution to this scope?

What I have tried:

I try to remote connect from Visual Studio by Add server, but I can receive any signal from Linux server.
Posted
Updated 6-Oct-19 23:27pm

1 solution

 
Share this answer
 
Comments
Andy_Bell 9-Oct-19 15:55pm    
Ok. I tried to follow your suggestion. I have defined new entry in "Connect to remote system" in Cross Platform verifying correct connection. I have use "Native GDB" selection.
But I can't attach to process when I'm starting debug attaching to remote process, previous defined. I get this error message "Unable to start debugging. Attaching to process ... with GDB failed because of insufficient privileges".

How can I resolve this?
phil.o 9-Oct-19 16:08pm    
Did you install gdbserver on the linux target?
Andy_Bell 9-Oct-19 16:25pm    
It's present only GDB package in Linux target. Do I need to install also GDB server?
Are there other requirements? How can I set GBD server?
phil.o 9-Oct-19 16:31pm    
I think it is mentionned in the article:
"In gdbserver mode, GDB is run locally, which connects to gdbserver on the remote system. Note that this is the only mode that the Linux Console window supports"
Since there is a strict process isolation between windows and linux, you need to have some kind of bridge between both systems: the windows gdb client / linux gdb server plays that role.
Andy_Bell 10-Oct-19 16:03pm    
I have installed GDB server in remote machine. I have enabled remote connection as root user. Now Visual Studio can start correctly debugging attaching to Linux remote process.
But I have another problem: it seems breack points are desabled. Why? Is it normal condition?

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900