Click here to Skip to main content
15,902,904 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
Getting this lovely error:

24:36:00:
24:36:00:Started Face Processing module
24:36:00:face.py: Traceback (most recent call last):
24:36:00:face.py:   File "C:\Program Files\CodeProject\AI\modules\FaceProcessing\intelligencelayer\face.py", line 21, in 
24:36:00:face.py:     from request_data import RequestData
24:36:00:face.py:   File "../../SDK/Python\request_data.py", line 8, in 
24:36:00:face.py:     from PIL import Image
24:36:00:face.py: ModuleNotFoundError: No module named 'PIL'
24:36:00:Module FaceProcessing has shutdown
24:36:00:face.py: has exited


I know PIL is not supported anymore and you have to use Pillow now, but I am also new to Python, so I'm pretty lost when I try to install it or set it up.

What I have tried:

Tried re-installing CodeProject server.
Tried installing Python from the website and then pip installing Pillow.
Tried installing Pillow through Anaconda.
Posted
Updated 14-Sep-23 8:30am
v2

There is a dedicated forum to discuss this: Artificial Intelligence Discussion Boards - Code Project[^]
 
Share this answer
 
Comments
Richard MacCutchan 21-Aug-23 4:03am    
That's the wrong forum for CodeProject AI issues, see OriginalGriff's answer.
Graeme_Grant 21-Aug-23 4:06am    
How did I get that wrong ... I do know the correct one... lol
Richard MacCutchan 21-Aug-23 4:41am    
Same way the rest of us get things wrong ... apart, that is, from OriginalGriff and Richard Deeming who seem never to make mistakes.
Graeme_Grant 21-Aug-23 5:04am    
I would not say that. But yeah, 99% of the time...
There is also a dedicated CodeProject.AI Discussions[^] forum which might be more relevant.
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900